Home > Release Notes (public) > Cloud Cruiser 3.1 Release Notes > System requirements

System requirements

Overview

​The following are the minimum hardware and software requirements for Cloud Cruiser and its components.

Cloud Cruiser recommends that you install Cloud Cruiser, Cloud Cruiser Analytics Server, and your database server on separate computers. These system requirements apply to that architecture.

Cloud Cruiser computer

You should also install Cloud Cruiser Analytics Desktop on this computer.

Hardware

  • 2 GHz or faster multi-core processor
  • 4 GB or more of system memory
  • 2 GB of storage

Operating system

You must use the 64-bit version of one of the following operating systems:

  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Linux with a v2.6 or later kernel

The Server Core installation option of Windows is not supported. The Cloud Cruiser installer requires a graphical user interface and cannot be run within a command window.

Java platform

The 64-bit version of Java Standard Edition 7 (JDK or JRE) is required. Version 8 is not supported.

You can download Java at http://www.java.com/getjava. The navigation of this site changes often, so you might need to look carefully to find version 7 in 64 bits.

Cloud Cruiser Analytics Server computer

Hardware

  • 4-core, 2.0-GHz CPU
  • 8 GB or more of system memory
  • 2 GB of storage for installation and initial use. You will need more space in the future as Cloud Cruiser accumulates data over time.

Operating system

One of the following operating systems:

  • Windows Server 2003 R2 SP2 or higher
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows 7
  • Windows 8

Database server computer

A database server is not included with the Cloud Cruiser installation. You must provide one of the following database servers:

  • Microsoft SQL Server 2008 or 2012
    ​The Express edition is not supported. Its limitations will result in unacceptable performance, even in small installations.
  • Oracle 10g or 11g

​​For hardware and operating system requirements for this computer, see the documentation for your database server. Storage needs will grow as Cloud Cruiser accumulates data over time.

Client computers

One of the following browsers:

  • Microsoft Internet Explorer (IE) 10 or newer
    Although the product works on 32-bit versions of IE, Cloud Cruiser strongly recommends that you use the 64-bit version of IE for better performance.
  • Mozilla Firefox
  • Google Chrome

As of the last update to this article, Cloud Cruiser has been tested with Firefox 32 and Chrome 37, and we continue to test with new, automated version updates of these browsers. The application should continue to function with such versions. However, some issues could arise that can only be resolved with subsequent patches to Cloud Cruiser or by reverting the browser update.

You must to post a comment.
Last modified
17:52, 23 Jan 2014

Tags

This page has no custom tags.

Classifications

This page has no classifications.